Change the name of a groundplex/feedmaster

I have installed a groundplex and feedmaster, both are showing up in the Dashboard using the default machine name, I want to change the name to show up as the DNS entries that we have configured.

I have tried two approaches, but neither had any effect:

  1. Adding the config property to the global properties file
    jcc.jvm_options = -DSL_INTERNAL_HOST_NAME=my.domain.com -DSL_EXTERNAL_HOST_NAME=my.domain.com
  2. Adding the properties to the NODE_PROPERTIES tab in the console

After various rounds of restarts, the original machine names are still being used then I create new tasks and assign them to the feedmaster.

Can anyone help with a configuration method that is known to work?

I had this same issue and tried the same with no luck. I used the LoadBalancer setting in GroundPex configuration settings and got it to work there with one exception. If you are using SSL to groundplex then use HTTPS. It does not strip the protocol off of the DNS name. Acknowledged bug by SnapLogic and it in their change log.