Diff snap exceptions

I’ve been trying to make a simple comparation between two table from differents databases. They have the same data type, the same name and are sorted by the same key.
But no matter how I try to do this comparation it still going to the modified output even though they are not diferent

It happens with numeric and date data types.

What I need to know is if there is some king of exception of data type or data bases that the diff snap doesn’t work as well as it could?

I alredy tried to converted this data types to strings but it still doesn’t work

P.s.: I’m working with Oracle and Postgres

@GABILOBATO, I have run into similar situations in the past trying to compare database data types to “seemingly” same data types from other systems or databases. Differing database systems treat numbers and dates differently and the database reads result in different JSON outputs. The SnapLogic pipeline validation output may not catch the subtle differences, so it’s hard to catch. (it’s rare, but it has happened)

Therefore, one thing that may help is to capture the database outputs directly to a JSON file and then inspect the output visually in the file. You may find subtle differences in the numerical and date output and may need to use a parseFloat(), Date.parse(), or similar methods to synchronize the types.

Did that and actually helped. But instead using the conversion methods we developed a ‘new’ snap using python and it’s working. Thank you for the point of view