Extra column Error

Hi everyone ,
I am facing once error while parsing data from CSV parser. It is showing me one error “The number of CSV data fields is greater than the number of header columns in the input data”.
I am attaching the screenshot of file PFA

Can anyone help me in this to add automatically new headers in J and K column like AA and BB for header. So that can process this file.
I have also tried with Trim the records with all the data is not processed.
Can anyone look into this.
Thank you in advance.

Hi mjain,

You need to change few configuration in CSV Parser. Add column names in the column fields and Skip lines fields to 1 which will remove the csv file field name and replace with the column names you specified.Also need to uncheck Contains headers and add Header size error policy to Trim record to fit header.
Hope this resolve your issue.

Thanks,
Pratiksha

@mjain As per your attached pic, I can see in column “J” has data(0) but no header name available after dddd .Please add header name there then it should work.

Thank it works.