File Writer FTP write-only access error?

We have a use case where we need to send a file to an FTP site that restricts users from reading from, or navigating directories. We’re only allowed access to put files on the server at the directory specified.

When I attempt to deposit a file generated in SnapLogic to the directory using a File Writer snap, I get the following error:

After talking with our partner who hosts the FTP site, we came to the conclusion that the File Writer snap might be trying to read the directory first (or firing some other unknown command) which results in the 426.

Is there any way to simply ‘put’ a file to an FTP directory using the File Writer snap, and bypass reading the directory first (or using any other command)?

Hi whaleyl,

Have you tried specifying the permissions for the user in the file writer snap?

Regards, Jovan.

Hi Jovan,

Thank you for the feedback and help. I had not tried doing that, no.

I went ahead and supplied the following write only permissions to all types of users that are listed in your image above but unfortunately and am seeing the same error:

Did I setup the permissions per user type correctly?

Hi whaleyl,

You should specify at most one row per user type (not three).
Than you need to liaise with the FTP owner so he could tell you the File Permissions and which User types have authority to write/execute files to the directory.
In the meantime i’d suggest to try accessing only with User type: others, File permissions: write.

Additionally if you choose the route error data to error view in the Views tab, it might give you more detailed explanation of the error.

Regards, Jovan.