Filter snap throwing error

Iam getting below error ,please correct me.image

Message error as below :
Failure: Could not filter document., Reason: Filter expression: Sales is undefined. Perhaps you meant: parseFloat, isNaN, snap, jsonPath, Resolution: Please check the spelling of the variable

Please help.

hi, could you please provide info on what is the input to filter snap, and what is your filter criteria, if its something like for ex: sales greater than some value, your filter expression should be $sale > value.

Regards
Anubhav

No , Sales is the Department name , filtering for only department field having text value Sales.

if your field name is department and value to filter is sales, your filter condition should be $department == ‘sales’

Thankyou Anubhav , this has been passed , filter data is appearing after clicking circle on the snap.
But this time File writer is wrtiting somewhere the files ,iam searched all Manager> Shared>Files etc.but not found the 2 output files.

the pipeline which you are running, is it in shared folder? or some other folder, the files will be written in the same project space where pipeline is residing unless you have specifically provided a particular path in file write snap

I think it is in projects folder.

your pipeline is in your folder(Sanath), could you please show the setting of the two file writer Snaps.

Regards
Anubhav

BTW Maybe this is variable, or can be avoided in some way, but it is a good idea to determine where the files are wanted, and what space you can use.

For example, at least with reltio’s implementation, you are limited to something like 100K. I might be wrong, and it may be 100M, but these days you are likely to exceed EITHER!

I ended up using MY ORGS shared folder for files, and that was only for SMALL files that were a good deal smaller than even 100K. The actual sources varied, but some were FTP files that I moved to S3 and read from there. If I had to write out “flat” files, INCLUDING REPORTS, I did THOSE to S3 also. Some of those files are over 100GB.

ALSO, watch out on shared folders. It looks like you only have two, so as long as the pipeline is in a folder underneath the projects fold, and you still only have two levels like that, for local files, you can put the file under …/shared/filename, with “filename” being what you want to call the file. THEN, your file will always be in the shared folder right under projects. REMEMBER though, make sure the admin and user are OK with that, and you don’t exceed a quota.

ANOTHER thing, just so you know. White space, like that on the reader in your picture, indicates the snap isn’t connected. So if you aren’t getting any data, that is why. One neat feature SnapLogic just added, in the last release that you should have already, is an option to disable a snap. It does the SAME thing as idsconnection, but:

  1. Disables the snap.
  2. Puts a red circle with a slash through it, to be more obvious
  3. Is FAR easier to set and reset.

It is under the execute options for the snap. Instead of an enable preview option, it has a list. “RUN”,“RUN&PREVIEW”,“DISABLE”…

One thing that makes disabling a snap is different that disconnecting it, is disabling a snap disables all snaps connected downstream from itself. So, in this case if the file reader was disabled, and its output view was connected to the CSV parser, the entire pipeline would be disabled downstream and nothing would run.

You could however keep the snap disconnect and disable it to get the obviousness of the non data flow happening through the disconnected snap.

File1setting1 File1-setting2 File2-setting1 File2%20-setting2

what are your settings in the account section of your file writer snaps, also in one of your Snapshot earlier, I can see your file reader snap and csv parer are unconnected.

Regards
Anubhav