How to pass values to a child snap

I am a newbie to Snaplogic. I am developing a pipeline to copy data from Oracle tables to Snowflake using Snaplogic. I have created a parent pipeline and used “Pipeline Execute” to pass values to the child pipeline. I am having trouble understanding the concept of parameters, fields, $, _, _$. Everything is confusing me to the World’s end. I wish there was proper documentation for that.

The parent pipeline works perfectly and it displays data as expected. But I don’t know how to pass those values to the child pipeline. I have attached the pipelines here.

Please help me understand how the whole parameter concept works in Snaplogic.
Parent_2021_06_17.slp (6.6 KB)
Child_2021_06_17.slp (29.7 KB)

It looks like you’re very close. You just need to enable the expression button toggle (=) for the first and third expressions in the Mapper at the beginning of the Child pipeline:

Hi Taylor.
Thanks very much for replying. I made the change as you suggested but the output view in the child mapper doesn’t show the data as expected, even though it validates “green”. Is that expected or I am mistaken?

Screen Shot 2021-06-17 at 12.35.21 PM

Hi. Unfortunately our UI doesn’t support a way to preview the output of snaps in a child pipeline when executed from the parent pipeline, so what you’re doing here is just executing the child by itself, correct? When you do that, the values of the pipeline parameters that the Mapper is referencing aren’t coming from the parent pipeline; they are just the default values of the pipeline parameters:

Hi Taylor,
I am actually executing the parent pipeline. So, shouldn’t the child mapper display proper data? Thanks again and your quick response is much appreciated.

Unfortunately, no. When you preview the parent, you can only see the preview output of the snaps in the parent. There’s no way to see the preview output of the snaps that executed in the child during the preview of the parent. The preview output that you’re seeing in the child pipeline is left from when you last previewed just the child pipeline by itself.

Taylor,
Thank you. I am bit more clearer and closer to the fix now. I enabled all the snaps and all but validated one. Please see attached. I tried with and without toggling the “=” button but neither works.

Those expression buttons are toggled off. You definitely need them on. What’s the error when they are on?

Peter,
I removed the “mapper” snap from the child pipeline and mysteriously it worked. I always had issues with Mapper snap. I did a successful validation and execution. Data got loaded successfully from Oracle to Snowflake.

Thanks very much for your help. Cheers!

Also, I have a suggestion to make: more and more people are using Dark theme in browser as I do. Snaplogic isn’t compatible with dark theme. I was able to understand and see the difference of toggling the “=” buttons better in normal light mode. Dark mode makes it harder to toggle.

HTH.