Join snap giving error

Trying to design a pipeline as shown above, where I have a json having failed Pipeline data from which I am picking each pipeline ID and extracting logs from Logging API, the result of the both 1st step and last are used to perform an inner join where both the pipeline ID would match, however when I run this I get the error,

Input not completely consumed
Resolution
Please raise a defect with the following information, Pipeline Ruuid:6bee3dc7-a754-4e5a-80c9-7a4a80555128
Reason
Snap failed unexpectedly and did not provide any reason

Need some help to understand on this, also would like to understand why this error is not shown while validation?

I could solve the issue but now there is another problem in accessing the JSON fileds,

jsonPath($, "PipelineData[*].*['ChildPipelineInstanceId']) jsonPath(, “$PipelineData[].['ParentPipelineInstanceID ']”)

both these expressions should give me correct result, but surprisingly, I get an error “Failure: Invalid JSON-path: $PipelineData[].[‘ChildPipelineInstanceId’], Reason: Field not found in JSON object: ChildPipelineInstanceId, Resolution: Check the path syntax”

I even tried different path : jsonPath($, “$PipelineData[]..ChildPipelineInstanceId”)

Below is my JSON :

is missing an end double quote. Is that the case in your Mapper?

No, may be thats just a typo, jsonPath($, “$PipelineData[].[‘ChildPipelineInstanceId’]”) even this is not working.

When I drag and drop, I get the path : jsonPath($, “$PipelineData[].pipe1.ChildPipelineInstanceId") which gives me correct value, but the moment I change it to jsonPath($, "$PipelineData[].*.ChildPipelineInstanceId”) I get the same error.

Try using a JSON splitter before mapper1 with this expression: $PipelineData[].

if it doesn’t work please provide sample data.

can you enable null safe access and report back?