Kubernetes for snaplogic - custom metrics not working

Hi i have been following the tutorial from the Snaplogic documentation https://docs-snaplogic.atlassian.net/wiki/spaces/SD/pages/2017558845/How+to+Deploy+a+Groundplex+in+Kubernetes about deploying Groundplex in Kubernetes.

When i deploy the prometheus adapter and check the custom metrics api with this command
(kubectl get --raw /apis/custom.metrics.k8s.io/v1beta1 | jq . ), I am getting empty response - resources field is not populated with values. I have also attached the response from the api i am supposed to get , and the one that i am getting.


ResponseGetting

Any help on why i am getting empty resources field without any values would be appreciated.

Hi @Igor_Bozhinovski

I reached out to our Kubernetes team. They have some questions:

  • Is cluster enabled on the Snaplex manager Nodes tab? (enable_k8s_auto_scaling)

  • Could you share your kube-prometheus-stack’s custom_values.yaml and prometheus-adapter’s custom_values.yaml files ? (please mask any sensitive data in these files)

  • What cloud provider are you using? AWS EKS?

Another route is to create a support ticket where you’ll probably feel more comfortable sharing your configuration. However, maybe we can solve this with just a little more information. :slight_smile:

Hi @mbowen,

The cluster is enabled on the Snaplex manager Nodes tab:

Here is the file for the prometheus-kube-stack i’ve attached it as txt because i wasn’t able to attach as yaml file, i am using same values from the documentation:

custom_values.txt (1.4 KB)

Here is the file for the prometheus-adapter attached as txt, i am also using the same values from the documentation:

adapter_custom_values.txt (583 Bytes)

Additionally as cloud provider i am using Azure , AKS cluster.

My colleague also has the same problem , is using AWS EKS as cloud provider and the custom metrics aren’t appearing also.

Additionally the Snaplogic chart for Grafana that is avalible on the SnapLogic Snaplex Dashboard dashboard for Grafana | Grafana Labs seems to be outdated, it would be nice if it could be updated to scale with the latest version of kubernetes.

Hello @mbowen and @Igor_Bozhinovski ,

I`m having the same problem on AWS EKS cluster with the custom metrics API, using the same configuration files as above.

Also I`m getting empty response in the resources field, the custom metrics are not registered in the custom API.

@Igor_Bozhinovski @AnetaTrajkovska
Thank you for the information. I’ve passed information along to our K8 team.

@Igor_Bozhinovski

Could you please create a support ticket to resolve this issue ? You can copy and paste what you’ve provided here. I’m sorry to have to ask you to do this, but with the holidays, absences, etc… I’m afraid the response time here may be delayed. Logging a support ticket will ensure traction on this issue.

Happy Holidays!

@mbowen

I’ve created a support ticket to resolve this issue, in the meantime if you get any response could you please provide it here also ?

Happy Holidays to you too !

Hi @mbowen

The issue now seems to be resolved , i am not sure if there was some changes from your side. The custom metrics are getting registered as supposed. Thanks for the help.

1 Like