Load .xlxb workbook with multiple sheets to oracle table. Load only one or specific sheet data only

I have .xlsx file on remote server. My requirement is to load the file content into an oracle table.
Any help is appreciable, Thanks in advance.

The easiest way to do this is to use a combination of these Snaps:

File Reader > Excel Parser/Formatter > Oracle Insert

The File Reader Snap supports reading data from a variety of remote systems.

The Oracle Insert Snap can be used to load data from the upstream source into the Oracle table. Alternatively, for bulk data loading requirements, you could use the Oracle Bulk Load Snap

Thank you sriram.
I have gone through parameters of File reader snap, it supports different protocols but I had below query:
a) server path I am accessing is like : \\Rsc.aaaa.com\rdrive\D00\AllDept\SHARED\ComRead\MA\2018
in the snap Settings >File syntax is - ftp:// “path”
I am giving as ftp:\\Rsc.aaaa.com\rdrive\D00\RRRRRR\SHARED\ComRead\MA\2018
the snap is throwing error.
b) There are many files in that path, I want to read only a single file and the name of file is dynamic(changes periodically but will have a specific pattern). I don’t find an option in the file reader snap to mention file name, please suggest on this

Are you attempting to access resources from an FTP server that has been mounted on a Windows server? And, is the error about authentication / connection failure? If yes, you will have to create a “Binary > Basic Auth” account and reference it in the File Reader Snap.

Thanks sriram, I have modified my query.
I am able to read the file using File reader snap, but I am unable to read the contents of document.Capture

my required file is in tab- “content-disposition”
Please guide how to fetch the document further and extract data from specific sheet of the workbook.As you have mentioned , I tried connecting excel parser/formatter to file reader snap but couldn’t as there is mismatch on type of snaps.

You should be able to read data from the source .xlsx file by connecting the Excel Parser snap to the File Reader Snap.


If you are unable to do this, please post a screenshot of the error message that you see.

Data format in one of the sheet - “Yearly”

I am trying to read data from row #13(actual data with header) by setting sheet index =2 and sheet name - Yearly(I am aware sheet index is overwritten when sheet name is specified), tried either ways I am getting below error

I’ve created a sample pipeline that successfully reads a small dataset. Formatting of the source file is inline with your setup. Can you review the xlsx file and pipeline (attached) and let me know if that matches with what you have?

Excel-Test_2019_02_20.slp (4.3 KB)
Test-Excel-File.xlsx (29.9 KB)

The pipeline works fine to read xlsx file. But if you look at the file type I am mentioning it is xlsb(Microsoft Excel Binary Worksheet) so Excel Parser is throwing error as it is getting binary document.

The Snap is only compatible with xlsx or xls which represents data as XML internally. However, the Snap appears to be incompatible with parsing a file that is in xlsb format. Can you please reach out to our Support channel (support@snaplogic.com) to track this as an enhancement request for the Excel Parser Snap?

@sriram, Can you please forward this to the concerned team on my behalf? Thanks

I am facing same issue, unable to parse xlsb file. Please share solution if you have figured out.

@nmadulapally as per the discussion it seems the snap is incompatable to parse xlsb file.
Can you brief your requirement?

Thanks Siva, my requirement is to parse xlsb file and read one worksheet.

@nmadulapally I suggest you to use Excel parser snap