Monitor Pipelines

when using the following rest call:
GET /api/1/rest/public/runtime/?

it works fine for up to 40 hour limit, but after that it just stops returning data

image

any help would be appreciated

@jason.steindorf - when you say it stops returning data, do you mean it returns data but nothing past about 40 hours? Or if you specify a last_hours value greater than 40, the call doesn’t return any records?

The first screenshot shows that data flows through and ‘last_hours’ is set 40

And the second screen shot will show that data STOPS flowing when set to 45, ideally i want to go back 1 week(168hr)

1 Like

If you execute the pipeline rather than use Validate Pipeline to see the data previews, can you see if there are any documents that pass your “Remove child pipelines” filter?

My guess is that you’re seeing an artifact of a small value in your User Settings “Preview Document Count” (default is 50). You could also try setting that to a higher value and see if you preview passes any records past the filter.

Even if this is the case, you may run into the 1000 record limit of the first API call to get the list of pipeline executions. There are 2 settings on the REST Get snap (Has Next and Next URL) that will allow you to paginate through the responses. I have attached a sample pipeline that shows how to use these settings, specifically for the Pipeline Monitoring API.
Pipeline Monitoring Pagination_2022_09_08.slp (8.6 KB)

1 Like

I added in the the hasNext and nextUrl but still no luck, can we set up a zoom meeting for next week

1 Like

i was able to modify your pipeline to my needs, thanks again, greatly appreciate your help

1 Like

Great! Happy I could help!

1 Like