Partial File Creation using File Writer on FTP Destination

Hi,

I am getting this weird issue of partial file creation while using ftp as destination. File size is less than 3 MB.

I have tried below things but none of them seem to work:

  1. Changed FTP Destination server to rule out if issue was on specific FTP destination.
  2. Tried changing file format from .txt to .csv, .dat but same issue.
  3. Loaded content of file in DB and then reading the data from table and creating the file but again output file is sometimes partial file.
  4. File is getting created perfectly fine on sldb. Tried pushing it from sldb but again at destination its creating partial file.
  5. Only data getting truncated is at the last.

Does anyone faced such issue? If yes, how you handled it.

pipeline

Hi Prateek:

FTP issues can be a bit tricky to debug, especially intermittent ones. Maybe a good next step is to log a support ticket. It doesn’t sound like there is an explicit exception being raised, however, there is some logging written by the snap that support will be able to inspect that may help troubleshoot this issue.

Being able to reproduce the issue from our end, helpful of course, too.