REST Post Trying To Send a CSV File

restful_post_example.docx (314.4 KB)

Hello Everyone. I am brand new to SnapLogic as well as brand new to RESTful API’s so please bear with me and not make fun of me too much. :slight_smile:

I attached a document to help visualize what I am trying to do. I am just trying to do a proof of concept for a project using the REST Post snap to upload a CSV file but I cant get it to work and I was wondering if someone might be able to help point me in the right direction.

Thanks in advance for your kind help!


@steven_rossi, When equal sign is toggled ,snapLogic treats the value as expression and validates. In your case if the REST url is static try disabling expression by clicking on equal sign and execute the pipeline.

Thank you kindly for replying. I toggled off the = on the Service URL and that seem to move me at least to the next error that I am getting, which is:

Name may not be null
Please raise a defect with the following information, Pipeline Ruuid:f3729f84-ec0b-4f50-88f9-874504110774

@steven_rossi,Can you try same for query parameter value and remove empty header parameter ?

Thanks. I ended up deleting the Snap and adding it back making sure to set everything as you described. I am not receiving any errors now with the snap itself I am just not getting the results I am expecting when it runs. Its not actually creating a user when I look it up on the other system.

How I have it set now that the Rest POST doesnt error and the JSON Output

I am not getting any error back or something informative in my JSON Formatter to help me identify any issues. Is this the correct way for me to be checking this, is by way of the JSON Formatter (I know the API is supposed to return JSON)?

I think at this point my issue is related to the other system so I will be following up with them as well to see if I can identify my issue. Am I missing something else?


Better picture of JSON Formatter:

@steven_rossi, Rest snap should provide you JSON as output document. Can you try validate your pipeline with “Execute during preview” option enabled on Rest Snap properties.

Good Morning @psadasivam. So I turned that check box on and ran it and it appears to be going through correctly as I am getting a 200 status. Whats interesting is it appears to be passing in my own information rather that the one that is in the file I am trying to load. What am I missing?