SAP IDoc Write

Hi Team,

I created one pipeline which writes an IDoc to SAP using SAP IDoc Write Snap. IDoc is generated at SAP side but, I am getting error for the IDoc write snap [please see the below image for the error]. What configuration do I need to change in the snap to get the IDoc number from SAP?

  1. I checked with and without status codes - getting same error.
  2. I checked with and without Read BAPI ‘IDOC READ COMPLETELY’ [which is existed in SAP but, processing type is not set to ‘Remote Enabled’] - getting the same error

This could be due to a LOT of things. Unfortunately, it seems that 100% of all “cloud” software doesn’t even try to explain one error that a LOT of companies have a problem with.

SAP, to the best of my knowledge is generally LOCAL software. It is also expensive, and used for almost everything. Given that, it is likely behind a firewall, or protected in some way.

If all that is true, and you used the regular cloud service from snaplogic, it probably couldn’t reach and/or connect with the SAP instance, and that would explain this error very well. If that is the case, you have to find a way to allow snaplogic to connect, or go around, or have a groundplex(snaplogic can help you with that, and I don’t know the license specifics, etc…) installed internally(inside the company), etc… It is just the nature of the beast.

Thanks for your replay @stephenknilans. It is checking for the IDoc status and getting the error at fetching the status of the IDoc. I have given the polling interval to ‘0’ which means it won’t poll for the IDoc status. Now I am getting TID as output of that snap. I am able to fetch IDoc number by using that TID with some workaround.

Thank you!