Snaplogic connect to MS-Access MDB database

You can use the JDBC snap to access the MS-Access MDB database by using 3rd party JDBC driver. The example here is using the JDBC driver from UCanAccess.

Note that the JDBC driver will have no idea on how to access an SLDB:// location. The database file must be local on the groundplex or somewhere accessible from the groundplex.

I tried to implement this, but while validating the account I get the error “POST http://pa23sl-jccs-ux07672.fsac5.snaplogic.net:8090/api/1/rest/account/validate: Server Error”

If you are using the UcanAccessDriver, that JDBC URL doesn’t look correct since it won’t know the SLDB enviroment. That should be close to what the original stated but pointing to the file location on the node.

So where should the access file be stored? I tried the below still getting the same error,

The accdb file must be somewhere that can be accessed from the groundplex execution (not within the SnapLogic Database). In your example, it’s looking for a file in the folder /tmp.

Hope that helps.
Eric B.

thank you, it solved the issue.

Our groundplex nodes are on Linux. Does the Access DB file have to reside on a file system that’s mounted on the groundplex node? Or could it reside on a Windows network share that’s network accessible from the groundplex node?

I have used similar connection with accdb file in the groundplex location . I am getting another error “UCAExc:::4.0.2 unexpected end of statement”

Hello,

This looks like an issue with the 3rd party driver UcanAccess. I have tried another driver (Trial Versions of caigen driver) and it’s working fine.

Snaplogic is using updated the Hikari connection pool management library version. This newer version requires databases to be able to support a validation query of “SELECT 1;” or have the driver itself implement a custom validation method. If you run select 1 using caigen driver it’s working fine but ucanaccess driver is rejecting that query. If the driver is JDBC 4.0 compatible they should support isValid method.

– Please see the below doc.

https://docs.oracle.com/javadb/10.8.3.0/ref/rrefjdbc4_0connection.html

– Caigen links

http://www.caigen.com/download.html