SSO login issues

Hi ,

We have multiple Snaplogic orgs created which are using same Identity Provider ( IdP).
Today on one of the org i changed the IdP and when i tried to login back using SSO i received an error message
"Single Sign On authentication failed.SSO login cannot be used for users that are members of orgs that have different identity providers"
I’ve changed back afterwards the IdP on that org to the same IdP as was set up previously , but i’m still getting same error message.
What am i missing here ? why this is happening ?

Thank you,

I had a similar issue when adding a second org to SSO. I hope I’m remembering correctly, but it seems that I had to upload the same metadata file on both orgs instead of using the separate metadata files provided by the idP.

I’m using same metadata on all organizations.
What i’ve done is that i’ve just changed metadata on one org, but afterwards i’ve reverted back , but error is still there. Is like something is stuck on the backend of the snaplogic portal and is still seeing that organization with different IdP metadata.

Issue solved. Was a problem with the metadata Idm file.