Trying to put local file on GroundPlex on location in shared Windows directory

I have a location on our file server: share1.berklee.edu. For illustration purposes we’ll name the path as follows:

share1.berklee.edu\PR_Shared\Test eft

I’m trying to drop a file from the local GroundPlex to the location

My understanding is that within the File Writer snap I have to use the SMB command.

So, in the File Writer snap under ‘File name’ I have the following:

‘smb:\share1.berklee.edu\PR_Shared\Test eft\DNU_test.txt’

The pipeline validates and seems to run without error. However, the DNU_test.txt file is not showing up in the location in the shared drive.

I was getting permissions error earlier but we’ve created the proper account that’s setup in the Account tab of the File Writer.

Am I using the correct syntax for the smb command? Should it be something else, like ‘file:’? I’ve tried that, pipeline validates, but file is still not being sent over.

Any insight would be appreciated.

Thank you,

Vin

I believe you need to start it with smb:\\

[edited to make it two visible backslashes as apparently the first one is an escape]

Hi vcocco,

Your slashes are the wrong way, and you need two / after “smb:”, like so if the expression button ("=") is pressed:

‘smb://server/share/folder/filename.ext’

Here’s a bonus hint: if you are piping the file name in to the File Writer snap from a Directory Browser–>File Reader combo, you can capture that name with a line like this in the expression:

‘smb://server/share/folder/’ + ['content-location'].match("[^/]+").toString()

This uses a regular expression to pull the name from the ‘hidden’ variables that pass through some pipelines, and converts it to a string. You can look for them after any snap by adding a Mapper and then holding Shift while you click Validate (this forces a refresh of the cached validation data) - the left side of the Mapper should show you any additional values for your use.

Mark W.

Hi Mark,
Thanks for your response.
So, the syntax has been modified - the slashes are now facing the correct way. Here’s what I have:

“smb://share1.campus.edu/PR_Shared/2019 TEST/TESTFOLDER eft”

Still getting this error:
Failure: Failed to write to smb://share1.campus.edu/PR_Shared/2019 TEST/TESTFOLDER eft, Reason: Possible reasons can be failure in URL connection or file access denial, detail: Access is denied., Resolution: Check for URL syntax and file access permission

We do have an account in our GroundPlex that’s setup to access a shared SMB drive. I’m wondering if it’s just a permissions problem at this point?
Thanks again,
Vin