Workday API Issue

Hi Community,

Can any one help me out with the below Issue.
It used to work before, and Now I am facing the Socket Timeout Issue on the Web service. Any one faced this before. If So, can you please help me out with the Solution

On my First run, when I faced this issue, I used to re execute the pipeline and was working.
Now after many retries, I am still seeing the Issue.
Attached is the Screenshot of the Error.

Try to increase the Timeout value. Perhaps as time has gone on there is now much more data in the Workday tenant and the request is taking longer.

Thank you for the Response.

When I changed the Timeout to 0 or any other number like increasing it to 120 or other, the request runs for the couple of hours (More than 2 hours) which usually runs for 10 minutes and also it is hitting the performance on the Snaplex.

Although the process does not complete, I had to Stop the execution. So any other Solution on this?

Are you able to execute the web service request outside of SnapLogic, perhaps using the Workday Studio Web Service Tester, to see if the Workday web service is responsive? Also the Get_Academic_Appointee_Request has response group sections to limit the amount of data that is returned. Do you need the full response from this web service or could you exclude sections like personal identification and personal information to reduce the response size?

Awesome! It worked when I tried to Limit the amount of data.

Thank you for the Solution.