Zoom OAuth Connection

Has anyone attempted to connect to Zoom via OAuth?

I can connect and get a token via Postman, but my token in snaplogic does not populate.

I’ve looked at the netsuite oauth article that was published.

I’ve looked at the overall oauth with SaaS article.

However, I cannot get my access token to populate. My settings in SL match postman.
Here are my settings - what am I missing?

Hi @salesopsintegration,

Try enabling “Header authenticated”, also you may need to review method of authorization (Grant type) to “client credentials”

Thanks,
Pero M.

Hi @pmancevski,

Is your zoom connection, JWT, OAuth, or Server to Server Oauth?

When I did flip the Grant Type to client_credentials, I was able to get a token.
When I connect with the header authenticated, I get a 400 response.
When I connect without the header authenticated, and the Basic Auth header checked, I get a 401.

I have tried setting up both Oauth and Server to Server Oauth within the Zoom UI.

Hi,

If you manage to get the token, then i think you are good to go or i missed something?

Thanks,
Pero M.

It keeps denying me, even though it has a token now.

The OAuth connections do not work, but JWT does. I plan on reaching out to support to see if they can help.

Appreciate your thoughts!

Hi @salesopsintegration,

status code 400, in almost all cases means “Bad Request”.

Status code 401, means “Unauthorized”

Did you manage to authorize successfully the account? - if you already get the token probably you authorize successfully your account.

This means review configuration in your rest snap, or please send screen shot here :slight_smile: It would be easier to help.

Thanks,
Pero M.

@salesopsintegration, here is REST Oauth2 Account configuration that works for us:

image

2 Likes