401 Error using Https in API REST GET call

In house API call that works well in all browsers and postman returns “REST API service endpoint returned error result: status code = 401, reason phrase = Unauthorized, refer to the error_entity field in the error view document for more details” when using the REST snap

The following was tried and the issue persist
-Create account from REST GET similar to what is used to access API from browser (NTLM)
-Trust all certificates settings checked on REST snap
-‘Keep-alive’ connection added to Header settings
-Cookie details added to Header settings

Does anyone have any suggestion to assist in getting this error fixed

Do you have an error view on this REST Snap to see what it’s sending to the error_entity field?

Hi yes i do,

Strictly from my own stumbling blocks with REST APIs:

  • Make sure the expression toggle (the equal sign button) is not selected if you are passing straight text, but is if you are using an expression.
  • Make sure headers are in the HTTP Headers section, not the Query Parameters (I’ve done this more than once :smiley: )
  • Any other headers needed like content-type?
  • Check for case-sensitivity.

Yep expression box = sign is not toggled as i am passing text
the http headers are placed under headers
and the query is passed under the query

What about if you don’t have Trust all certificates selected?

I have tried the follow combinations all with the same issue

-unchecked ‘Trust all certificates’ and leave headers and follow re-directs
-Check ‘Trust all certificates’ and leave headers and follow re-directs
-unchecked ‘Trust all certificates’ and follow re-directs but leave headers
-unchecked follow re-directs but lchecked ‘Trust all certificates’ and leave headers
-Checked both ‘Trust all certificates’ and follow re-directs but remove header settings

@debra.paponette Did you try from it from groundplex?

401 is an Authorization issue. If you can get that working with postman then you can replicate that same with Rest Get Snap.


Yes it executes on the groundplex. Its an internally built API (internal to the organization network) that has to be executed on the groundplex

The api works fine in postman with the same username and password set up in snaplogic. Hence my confusion that the rest snap error is complaining about an authorization issue

Do you know if your API relies on the header User-Agent?
We believe Postman autopoulates this header, but our REST Snaps do not.

Does not seem so. I unchecked the option in postman and the call returned

But if i were to add this setting to the snap what would the value be? I am unfamiliar with this setting and its use

One of engineers believed he saw it needed in one use case that had authorization issues.

Understood. How to do set it was what i was asking. I am unfamiliar with what the value would be for example in postman the value is PostmanRuntime/7.26.8. If i am to set it in the rest snap what value am I to put?

I’ve never used it, so I’ll ask the developer.

13 posts were split to a new topic: API query invalid in SnapLogic, but valid in Postman


I would also like to understand why I am having issues using the rest snap which is not working once i use API generated from a third party SDK that now only uses HTTPS eg: https://OurServer/ServiceName/Sericves.svc/getInfo?filter=filter

before the third party application upgraded we were able to use the rest snap as it was using HTTP eg: http://OurServer/ServiceName/Sericves.svc/getInfo?filter=filter

Note the HTTPS links works in other applications, the browser and postman but not in snaplogic.

Debra, please elaborate on “having issues”. That’s not much to go on.

Oh, sorry, I’m seeing that you were the one who started this post in the first place and have posted details. Let me review that and see if I can help. I’ve been focused on all the recent activity on this thread about a completely different issue.