account.property_map.settings.passPhrase.value: Missing property value

Hello Team,

when i try to validate sftp path through directory browser snap,am getting below error. i’m using SSH account for validation

Validation errors: account.property_map.settings.passPhrase.value: Missing property value

Resolution:
Please fix the snap configuration and try the execution again

Reason:
The snap settings are not correct

when i try validate other sftp connection same snap settings am able validate successfully.

Hello,
We also saw same error in our development environment and we’re thinking of putting a Snaplogic ticket for support. Was wondering if anyone in the community may have some insights too

Are these both with SSH accounts?

Hello,

yes, i tried with SSH account

And your seeing the exact same validation error on the same property(passPhrase) being missing? this may be an obvious question, but just being sure, is the value populated?

I’m Tam Nguyens’s colleague . Yes , all properties are populated and this was working just fine. We upgraded this environment 4.21 Patch#1 yesterday - Is that the reason ?

Yes , SSH account for us too.

this SSH account created 2 years ago without passphrase. how ever, as per our discussion with SnapLogic product team before we’re up graded to version 4.19, all the SSH accounts created till 4.18 version without passphrase will work with 4.19 also. only newly created SSH accounts needs passphrase as mandatory.

yesterday we upgraded our snaplex to 4.21 patch 1. above issue persisting after upgrade

On June 5th 2020, a patch was released for Binary Snap pack. Please upgrade to the latest patch.

4.21 Patch 421patches5871

  • When configuring the SSH Auth account type, SSH passphrase is now optional, whereas it was a required field earlier.