Connecting to SQLMX

I am working on connecting to a SQLMX database using the JDBC connection.
The connection is successful when I add the details in the JDBC account, but when I try to execute queries from the pipeline it throws error.

I could run the same query using SQL workbench tool. See below the screenshots.

Have anyone come across these errors? or if there is a known setting that is missed?
Any help will be appreciated.

*** ERROR[1183] Error 73 was returned by the file system on metadata table IFDB.DEFINITION_SCHEMA_VERSION_3500.OBJECTS (file name (partition \HPENS01.$S00X02.ZSD8KWJP.OBJECT00)). [2017-08-09 11:24:59] [SQL State=X0153, DB Errorcode=-1183]
Next: *** ERROR[4082] Object IFDB.DEFAULT_SCHEMA.KRUPALI does not exist or is inaccessible. [2017-08-09 11:24:59] [SQL State=42000, DB Errorcode=-4082]
Next: *** ERROR[8822] The statement was not prepared. [2017-08-09 11:24:59] [SQL State=X08MU, DB Errorcode=-8822]

/KS

Did you try the schema.tablename in the query?

Yeah, but still got the same error.
It got solved, not sure how.

But now when I am trying to use the same insert query in different ways I get this error,

Content of Json generator:

[
{

    "ACTIONNAME": "Audit",
    "TRANSACTIONID": "536b983a-bb79-4a0f-afa7-6c3b4a8890b9",
    "ENTRYTIMESTAMP": "2017-08-10T08:37:22.882",
    "EXITTIMESTAMP": "2017-08-10T08:37:22.882",
    "SOURCESYSTEMNAME": "_sSName",
    "TARGETSYSTEMNAME": "_tSName",
    "PIPELINEPROJECT": "PipelineProject",
    "PARENTPIPELINENAME": "_parentPipelineName",
    "CHILDPIPELINENAME": "_childPipelineName",
    "ASSOCIATEDPIPELINE": "_associatedPipeLines",
    "USERNAME": "_userId",
    "SNAPLEXNAME": "SnaplexName",
    "PARENTPIPELINEINSTANCEID": "_parentPipelineInstanceID",
    "CHILDPIPELINEINSTANCEID": "_childPipelineInstanceId",
    "BATCHID": "_batchID",
    "BUSINESSID": "_businessID",
    "STATUS": "_status"
}

]

Output of Mapper1 where we are getting error

Output of Mapper2 where it runs fine