Coupa OAuth2.0 Configuration without using Coupa SNAP

Here is the issue, the Default OAuth2.0 Snap does have Scope so Where I can specify the Scope
What Do I put as OAuth2 Endpoint? See screenshot.
Is anyone able to connect to Coupa using OAuth 2.0 Please share step-by-step? I was able to connect via Postman using the POST call that generates the Key, but not sure what I need to do with that key.
Currently, for the connection in Snaplogic, I have provided the Client ID and Client Secret. I get 500 Errors when trying to make the connection

scopes are specified in the Token endpoint config, you add a new key/value with the key being “scope” and value being the space-delimited scopes you wish to request.

1 Like

Thank you for your reply, I did try this, and seems this solve the initial issue but now I get 400 Error

Coupa Documentation states:

With that access_token set in the Authorization header you can make GET, PUT or POST calls to the Client scopes you defined for that Connection.

In this case, to accomplish this, check the “Header Authenticated” checkbox in the account settings, and that should resolve the issue for you.

1 Like

Thanks this solved the issue, I also follow the REST OAuth2 docs. Thank you very much

Just to update you that space-delimitated does not work so checking on this how I can specify 2 scopes

from my understanding of coupa, it needs to be specified on both sides, and from the snaplogic side, you’ll need to re-authorize when you make a change (if you just refresh, it won’t necessarily apply the update in scope). the coupa documentation states to space-delimit them (see screenshot below)
Here’s the link to their documentation for it - OAuth 2.0 Transition Guide | Coupa Unfortunately, I don’t see any specific endpoint configurations in their api documentation regarding the specific format expected, but I would suspect space separated is correct.
image

1 Like