File Writer not creating new directory

Usinf FileWriter snap I am trying to create a new direcorty ‘202303’ and write a file to that location

but it is throwing erro
however I am able to write a file to the existing directory(If i create a new folder named ‘202302’ manually then it is writing file to it),but its not creating a new folder if its not present.

Also I logged in using the same credentials that i am using here in an ftp application(SecureFx), and there i was able to create a new folder as the logged in User.

Any Idea what could b the issue

@ash42: Can you enable the “=” decorator and try again? Sharing a screenshot for your references:

No luck, Same error

With these settings, can you write a file to the existing directory?
If yes, may be check with your admin if you’ve rights to create a directory in that location.

The settings look good to me as I’ve been able to create directories with the same.

I did connect to the ftp server with the same credentials ,and tried creating a folder manually…I was able to create…Dont know why through snaplogic I am not able to create with same credentials

I believe you are missing a slash character in the file name. It should be:

'ftp:///' + 'simclrdat01' + ...