Getting The Response Header and not Response Content from Jira Webhook

The header is a JSON file and content comes in a binary file as can be seen from the trigger task debug trace below:

Tried using the pipeline below and I only get the response header also included below and can’t find a way to get the content:

As you disable your entry point (binary router) you can’t get your expected response. The response you get because you didn’t ignore empty stream in json formatter.

image

Thanks for your answer. I’m just starting to learn SL. So, I was trying to follow the following pipeline (JIRA event capture in real time via WebHooks and triggering Snaplogic pipelines) and don’t what conditions I can use for the first binary router snap. Also, I tried running the below pipeline and got no results/response, however, the triggered task debug trace does show the header and content. image

@Supratim Also when I run the snap, I can’t get any intermediate results or only empty json is being returned every time?
I can see the files in the debug trace and they look fine but when I check snap results, they are empty.

Also, when using REST API(GET/POST) snaps, the intermediate results in the snaps are not there.

@anayak Are you referring “Run Snap” as run pipeline? If you create an API which accept data (POST) and you run pipeline will not work. Either you have to use json generator with expected payload at the very beginning of the pipeline and once development done remove/disconnect/disable it or use Record-Replay snap instead of Json generator, and send expected payload via postman then start your development.
If you want to test your API by Rest snap during development, make sure execution label of all snap you used in your main pipeline (implementation ) should be validate and execute.