Groundplex is not visible though the user has full permission

I am using Snaplogic groups manage permissions and the groundplex is not visible to the user eventhough the user has full permission for the shared directory. Has anyone come up with this issue?

This may be a defect that needs to go through Support.

If a pipeline is created in a project where the user has write permission but not execute permission, then the plex selection dropdown and the execute icon are disabled. Try moving the pipeline to a project where the user has execute permission

Worth noting that this most often occurs when companies first start using SnapLogic. This is because the Snaplex is created in /shared, where users have Read / Write / Execute, but the default location for your first pipeline is in /projects/shared where users generally start with Read / Write but not execute.

default permission model does not make sense. They should be given execute permission to their own folder by default .