Insert Special character in sql server table

I have a sql server bulk insert snap which have a varchar column in table. and i have a input document to this snap having this data :slight_smile:
"• the ability to take part in daily activities "

when i am inserting this to that column in the table it is inserting as
" ò the ability to take part in daily activities "

so any reason why is this happening ,and any solution if possible so that the “bullet point” character get inserted to that particular column.

ps: I am able to insert that data manually in to the table

Any help appreciated

You may need to pass the -C (code_page) parameter to BCP. (I resolved some UTF-8 issues this way.)

I created a BCP.bat file that which my SQL Server Bulk Load snap references in the “BCP absolute path” parameter. Within the BCP.bat file, I have one command:

"C:\Program Files\Microsoft SQL Server\Client SDK\ODBC\170\Tools\Binn\bcp.exe" %* -C 65001

I hope this helps.

1 Like

Does this path work for cloudplex too, as the path seems local directory…Is there a workaround

@ash42, sorry about my assumption. We run the BCP tool for SQL Server Bulk Load snap on Windows servers on groundplexes. I am not aware if there is an available option for Linux servers, thus my assumption. The path I provided is the standard install location and command-line path at the time I installed BCP on Windows a year or so ago.

Sorry, I must defer to someone who is familiar with the Linux uses for the snap.

Interesting. because when I tried this it fails.


I confess I am not an expert on this process, so my offering of information is based on what worked for me. I originally had to experiment a bit and lean on the snap documentation and Microsoft BCP documentation quite a bit with trial and error. I eventually got things to work for our case.

But, there are a few things I failed to mention in my post above:
You must install each of the required executables on each node of your groundplex. Including the required ODBC version and BCP. The executable is launched on the node that which the pipeline is running. This also includes the bcp.bat file you create - must be installed on each node.

For my case, I let the installers install the applications to their default locations on the C: drive. However, we keep most of our service applications and dependencies such as SnapLogic and Java on the D: drive - which is where I created the bcp.bat file (D:\opt\BCP\bcp.bat). This is the path that I put into the snap configuration.image

I can’t confirm this will work for others, but I can confirm that it does work for us at this time