Invalid Certificate when configuring Oauth to Google Drive

I’m trying to follow the instructions here to enable access to my google drive. Per the instructions, I am using the Get REST snap and enabling the authentication. I created the google application id and got the secret.

When pumping this information into the Create Account screen (other parameters are as listed in that screenshot) and clicking the Authorize button, I am brought to a screen that asks me which of the several google accounts I have that I want to use. I do this and then a new browser table opens with the following message:

{“query_string”: “state=hostname%3Dhttps://elastic.snaplogic.com,instance_id%3Dfdc8bc74-6e29-4606-bff2-1351bb05d256&code=4/LVzTg4VmZwRFFq1gRS4HTzuKppqd3QfuRtkjcO1uz-0”, “path”: “/api/1/rest/admin/oauth2callback/rest”, “response_map”: {“error_list”: [{“message”: "hostname in certificate didn’t match: != OR "}]}, “http_status”: “400 Bad Request”, “http_status_code”: 400}

which seems to indicate a bad certificate. However, its not obvious to me that where a bad certificate should exist between SnapLogic and Google. Does anyone have an idea what I might be doing wrong?

Would it be possible to show a screenshot of your REST Snap Settings (expanded) please?

can you try checking the accept all certificates?

selecting the ‘trust all certificates’ checkbox did not help.

Here is a screenshot of the account screen. All htat is missing is the account and the secret:

Screen Shot 2017-11-09 at 9.07.28 AM

please note also that I am getting the google screen that asks permission for SnapLogic to share this data. I had neglected to mention that before. To me this indicates that much of the configuration must be correct, and the problem may lie in the redirect.

I assume you wanted the account settings…

I just realized that i was missing the ‘www’ in the Oauth2 token parameter. When I included that, I was able to successfully authenticate.

1 Like

Ah, I didn’t catch that either - thanks for following up.