Invocation of Ultra task fails

Hello Team,

I have created a test pipeline, where using Rest post I am invoking an Ultra pipeline.
The ultra pipeline is simple, it expects the $test input and sends the result back. This is only for test purpose.

Here is the input that I provide to the Rest post snap:
[
{
“url”: “https://URL/api/1/rest/feed-master/queue/Reece-Dev/-Project/Test/Test%20Task%20Ultra”,
“token”: “xyz”,
“test”: “1”
}
]
Here is a test pipeline :
image

The Rest post gives an error:

I fail to understand why does the ultra pipeline throw an error when I am passing $test object to it. Here is the snap of Ultra task :


image

Can someone help here please?

Hi @viji28,

Incoming JSON structure in Ultra pipelines is different, for better understanding i’ll suggest try add “Record Replay” snap at very beginning of your pipeline, just to see how it looks JSON structure in Ultra.

Fast answer if your request have body, then those parameters will be in content object ($content.test). Query parameters will be in query object.

Thanks,
Pero M.

1 Like

Thank you!

I tried using a json formatted and tried writing the input content to the file.
The incoming json structure is indeed different. Though we may think that we are sending json structure but when the ultra receives it, the JSON is under $content.