Null Safe access option for object value reference in JSON Generator snap?

Hi,

I’m trying to reference a value from the input object in the JSON Generator snap. The property is optional in the upstream snaps. If I straight reference it, I’ll get an “Invalid JSON-Path field not found” error.

Is there a similar way to the use “null-safe access” option like in the mapper snap in the JSON Generator snap?
Is there a way to use the $.get() method in the JSON Generator snap? I keep getting syntax errors.

Below is my property reference:
$['wd:Project_Data']['wd:End_Date']

This fails:

$['wd:Project_Data'].get("wd:End_Date")
$['wd:Project_Data'].get(['wd:End_Date'])
$.get(['wd:Project_Data']['wd:End_Date'])

Your first expression seems ok, but can it happen that the first object is also optional? If that’s so, you should use the .get() method at both levels:

$.get('wd:Project_Data').get('wd:End_Date')

Note that the .get() method allows for a default value:

$.get('wd:Project_Data','DEFAULT VALUE')

Thanks for the reply @bojanvelevski.

I think the issue may be that expressions are not allowed in the JSON Generator snap? The solution to my problem is easy enough, I’ll just put a mapper snap before my JSON Generator snap and use the “null-safe access” option to fill in the blanks where needed, but I am surprised this isn’t an option in the JSON Generator snap, and I’m also not sure if any expressions are allowed.

See the very basic chain-JSON Generator pipeline that demonstrates the problem. I can’t reference the input object with an $.get(“num”) expression.

JSON Generator Expression Test_2021_12_06.slp (4.7 KB)

Hi @Charles,

just try to map the field without any expression functions.

This is what I put in mapper before JSON Generator.

And here is what I am trying to map in JSON Generator.
image

There is the output.
image

But if you want to get null instead of empty string that would be different.
You can try to do it with apache velocity or maybe after the generator set one Mapper and replace all empty strings with null.

Regards,
Viktor

1 Like

Didn’t noticed that we are talking about JSON Generator snap. @viktor_n 's suggestion should work.

I’ve tried the same as I showed you in response above, only thing that I’ve changed was that I was using fields that you provided in the post and I couldn’t work them out anyhow.

I’ve also tried with apache velocity but nothing.

Problem are those “:” you have in the name. I don’t know why but you can not map fields in JSON Generator with square brackets.

Solution could be as you said to map the first in mapper and pass it to JSON Generator with null-safe-access, or with expression to remove those “:” from the name of the field.

Hi @viktor_n,

I’m now pretty certain that expressions don’t work in the JSON Generator snap at all (regardless of square brackets or colons). Posting to see if anyone can confirm, but I think the snap only takes pure JSON and a direct variable reference. It’s just a shame that it’s not null safe, so it requires another mapper snap before it.

The basic pipeline below highlights the issue, that no expressions, like “$.get()” are allowed in the snap.

JSON Generator Expression Test_2021_12_06.slp (4.7 KB)

Thanks,
Charles

@Charles Please note the following documentation at the top of the default template in the JSON Generator:

Enter your JSON-encoded data in this space. Note that this text is
treated as an Apache Velocity template, so you can substitute values
from input documents or the pipeline parameters. See the following
URL for more information about Velocity:
https://velocity.apache.org/engine/devel/user-guide.html

This means you can use Velocity syntax, not SnapLogic EL syntax, in your templates, like this:

[
    {
        "result" :
#if($msg)
        ${msg}
#else
        ${fallback}
#end
    }
]

Here’s a pipeline to demonstrate this:
Velocity Null Check_2021_12_07.slp (4.8 KB)

You can do the same on a single line like this:

        "result" : #if($msg) $msg #else $fallback #end

2 Likes

@Charles,
Like Patrick, I was also thinking Velocity (VTL) as a solution, but as I tried to solution your original post, the Workday namespace convention in the property names adds some complexity. I don’t know if Velocity beats the null-safe mapper for your particular use case, but it can be good info for your tool belt in the future.

The kind of ugly solution I came up with (in a one-liner) is:

[
    {
       "output" : #set ($pd = $['wd:Project_Data']) #set ($ed = $pd['wd:End_Date']) #if (${ed}) ${ed} #else null #end
    }
]

I’m not well versed in VTL, so there’s likely something a little cleaner than the above.

1 Like

Got it. That makes sense. Thank you for the explanation and syntax example!

@del, really appreciate the working example, thank you! Like you mention, I don’t think VTL outweighs putting in a mapper snap, but really glad to learn about VTL as a tool for potential future solutions. I guess I’ll have to read up on that a bit. Thank you for the start!