Once working pipelines are failing

Pipeline prviously working failing with cryptic error. Rerun from Dev studio works, so pipleine is not broken. Moving the task around seems to work for a few days, then the same error occurs, again a very cryptic error. Again, rerunning from dev studio works.

Hide Details…

FIN127[5e99977bdf487e001545567f_cbc6d5f9-8c9a-4cf0-8ba3-cde8bd422abc – 6df52c44-273b-4cc4-8766-1b799fb28f39] – PipeExec Completion Receiver
`com.snaplogic.snap.api.SnapDataException: Pipeline did not complete successfully
at com.snaplogic.snaps.flow.PipeExec$PipeCompletionHandler.run(PipeExec.java:1325)
at com.snaplogic.snaps.flow.PipeExec$1.run(PipeExec.java:599)
at java.base/java.lang.Thread.run(Unknown Source)
Reason: Snap errors: {failure=Pipeline failed to prepare, reason=java.lang.NullPointerException,
resolution=Please address the reported error}
Resolution: Fix the child pipeline errors and try again

Error Fingerprint[0] = efp:com.snaplogic.snaps.flow.J1VBXCkd`

We’re seeing the same behavior, pipelines that have been running for several months without major issues are now having the same exact error you’re also seeing.

We’ve quite recently updated this particular snaplex to 4.31 GA - and we didn’t really see this same error before that, so maybe it’s related to this?

Are you also on 4.31 GA?
did you get in touch with support yet? or maybe you found a solution (or cause) already?

Working with support on this it appears like a downgrade to 4.30 patch2 solves the issue for our case.
Support confirmed that they are working on this topic with high priority - as the downgrade workaround (as suggested by support) is not applicable beyond Jan 7th.