Would it be possible to add an alternative option to “Pass through”, which I’m roughly calling “Pass through and merge”. This would not nest the pass through data in an “original” object, and would instead retain the pass through data at the root and merge the output of the pass through snap at that level. I spend a large amount of wasted time tracking, referencing, and “fixing” unnecessary pass through nesting. This would be a large productivity improvement.
I agree with your request.
If I understand the problem you’re trying to solve, in the short term, will adding a mapper after your snap, with the following configuration, solve the issue?
It would be handy for the snaps that do pass through data, if you could specify the target path, perhaps with a default of “original” for compatibility, but with the option to change it (like just $, etc.)
There are a variety of ways of “handling” the way it works today. It would be nice not to have to jump through extra hoops though.
That would probably be a cleaner solution. Something roughly akin to the Mapping Root field on the mapper snap.
Out of curiosity, what snap are you talking about?
Pretty much all snaps that offer a pass through option. I use a wide variety of them, and almost always end up having to jump through some hoops to format things how I need after.