Problem with XLM Generator snap

I have a problem with generating xml file using XML Gnerator. I have a json and use Mapper snap together with XML Generator to create xml file.

My mapper looks like this:

So I mapped array to array.

The results of mapper looks ok, but I receive empty output from XML Generator snap:
So it shows that mapper doesn’t work correctly.

In the attachment I will send pipline.XML Generator Community Example_2019_10_17.slp (220.4 KB)

Please suggest how to solve this problem.

I can’t reproduce this. I imported your pipeline and was able to run it after removing the error pipeline, which you didn’t include. I got output from the XML Generator:

When I tried to Run (rather than Validate) the pipeline, the File Writer executed and indicates in error in the filename configuration where you use Date.Now() in your expression. It should be Date.now().

@ptaylor I am aware that there exists some output for the XML Generator, but as you see on your screen the tags (Worker) are empty and that is a problem. The output from Mapper has some data for Workers but XML Generator does not.

To be more precise, for JSON generator we receive JSON with information regarding 5 workers and some other fields. I expected that as output from XML Generator I would also receive only 5 tags workers (without additional tags), and each tag would contain information about one worker.
The template XML teoreticaly looks ok:

In mapper snap I mapped array worker from json and array workers from XML Generator but it doesn’t work.

Could you please tell me how the mapper snap or XML Generator snap should be set so that the output from XML Generator contains an xml file with correctly filled tags?

How did you generate the template in your XML Generator? Using an xsd file?

The expressions in your template don’t match the input document. All of the object names in that start with “peci:”, except for the ones you renamed in your Mapper. Can you remove that “peci:” prefix from everything?

@ptaylor Yes, I used xsd to generate the template.

The general situation is that I get xml files from api. For this file I have a generate scheme which I add to XML Generator.The xml file has a prefix peci, but it is absent in the scheme.
(For the purposes of this example, simply on the basis of this xml I created JSON as a source)

It seems very strange that using the file and the dedicated scheme I cannot map array from the source with the same array from the scheme.I’ve tried different options, also with removing the prefix, which of course is not the solution to the problem, but even in this situationarray of workers doesn’t map and the generator did not return filled objects.

I am enclosing the scheme and dedicated xml file in txt format, because I cannot add xsd format.
File.txt (31.0 KB) Schema.txt (137.6 KB)

@Dawid_Zajdel At this point I would recommend opening a ticket with SnapLogic support.