Problems with Date.parse() function

Hi, I have a problem with the Date.parse () function.
I cannot convert a String to date, the format of my string is the following: “dd/MM/yyyy”.
It only happens to me with some specific dates (with most data I have no problem).
The problem occurs with the following examples:
Date.parse (“01/04/1932”, “dd/MM/yyyy”)
Date.parse (“05/02/1939”, “dd/MM/yyyy”)
Date.parse (“09/12/1940”, “dd/MM/yyyy”)
Date.parse (“16/12/1943”, “dd/MM/yyyy”)
Date.parse (“12/02/1950”, “dd/MM/yyyy”)
And I always get a NaN as a result of the function.
Thank you.

Victor,
I can understand how 16/12/1943 would fail. But I tested 1932, 1940 and 1950 and had no issues
This in the mapper expression
Date.parse (“09/12/1940”,“dd/MM/yyyy”)
this is the result
_snaptype_datetime: “1940-12-09T00:00:00.000 UTC”

please try again

Hi @rdill,

I have quite similar problem while using Date.parse() function. (Sound to me that started after the new release)

I have a mapper and an input value that I’m trying to parse using Date.parse(). On the dynamic preview it is showing the correct output but when on the real output it is writing NaN instead of the date value.
Dynamic preview:

JSON output of the same snap (same field):

Hi.
I just tried again and got the following results.

@VictorC I’ve tried the same expressions and am not seeing the same thing.
What are the other settings in the Snap?
Is this validating on a Cloudplex or a Groundplex? Which version is the Snaplex on?