Rest post snap giving different response from Postman

Hi Team,

I am trying to use rest post snap in my pipeline and getting different response from Postman. Here is my pipeline . Please let me know how can i get the correct output from snap:





Response from snaplogic . see in bold. Also postman output given below in screenshot :
{
“response”: {
“statusLine”: {
“protoVersion”: “HTTP/1.1”,
“statusCode”: 200,
“reasonPhrase”: “OK”
},
"entity": {
*** “success”: true,***
*** “response”: {***
*** “data”: {***
*** “referenceToken”: “chain_3a17c51e8b8c4a4aeaf3bee2c31bbb79dd210caa44a4cce1f5bfc5a3184e4f9b”***
}
}
},
“headers”: {
“x-content-type-options”: “nosniff”,
“strict-transport-security”: “max-age=31536000; includeSubDomains”,
“x-download-options”: “noopen”,
“x-frame-options”: “deny”,
“connection”: “keep-alive”,
“x-permitted-cross-domain-policies”: “none”,
“x-dns-prefetch-control”: “off”,
“content-type”: “application/json”,
“date”: “Tue, 13 Oct 2020 07:21:06 GMT”,
“referrer-policy”: “no-referrer”,
“content-length”: “128”,
“content-security-policy”: “default-src ‘self’”,
“cache-control”: “no-cache”,
“x-xss-protection”: “1; mode=block”,
“feature-policy”: “accelerometer ‘none’; ambient-light-sensor ‘none’; autoplay ‘none’; camera ‘none’; encrypted-media ‘none’; fullscreen ‘none’; geolocation ‘none’; gyroscope ‘none’; magnetometer ‘none’; microphone ‘none’; midi ‘none’; payment ‘none’; picture-in-picture ‘none’; speaker ‘none’; usb ‘none’; vibrate ‘none’; vr ‘none’”
}
},
“original”: {
“header”: {
“Accept”: “application/json”,
“AUTHORIZATION”: “E799ED4CF2455AB6BB2E439CD7C0C6D3:Bv5Z+TVdrVsSH8oR9EvebSKBUAL6vHksGegBQdjbpTg=”,
“Content-Type”: “application/json”,
“$”: {
“X-ALTR-TIME”: “2020-10-13T07:20:27.969Z”
}
},
“body”: {
“empid”: “1”,
“name”: “Yash”,
“email”: “yash.verma@gmail.com
},
“url”: {
“url”: “https://dgl.preview.hhhh.com/api/v1/single
}
}
},

Postman Response :

Hi @yash.verma

Can you please, tell more details about your payload and settings of Postman
The same payload , same url, returns correct response from Postman, but not at your rest post snap… Try with removing the JSON.stringify() function from the HTTP entity field.

BR
Dimche