Unable to read/decompress .dat gz file

I am trying to read data from gzip dat file using file reader with decompress. But unable to read the .dat file and sometimes unable to decompress in SnapLogic.

Kindly let me know what are the files format SnapLogic can support? Kindly advice me on the same.

image

While I check with the team, have you tried using a ZipFile Read Snap?

Yes I have tried with Zipfile Read snap but its not working. Getting below error
image

It is CALLED gzip, but really isn’t a zip file at all. For example, you can’t have a gzip ARCHIVE. If someone wants an archive on gnu, they usually gzip a TAR archive. That becomes .tar.gz or .tgz gzip is more like compress, and the decompress snap apparently supports it. Set the scheme on the decompress to gzip. Auto, the default, MIGHT work, but try gzip.

Steve

I have tried with the same which you mentioned gzip but won’t works.
image

But I have used the first approach which I mentioned, i.e. File Reader > Decompress is working fine. I am not sure how it will work for huge size files. will check it and update here.

Anyhow thanks for your suggestions.

I am not yet sure exactly how snaplogic handles this, but MANY use it through a pipe. I had one customer that thought they had a T3. They effectively had a T1. We SATURATED the bandwidth, and they just didn’t like the performance. I was able to compress, transfer, and decompress, and process such that they not only got the performance they needed, but they have used it for years. And the routine I used was gzip

I am not sure the issue is as same I am facing. I too had issues with unzipping the file. They said the product team is working on the issue .

It does not happen always . It happens sometimes . I was not able to find out the exact reason when it is failing.

This is reply I got for that issue …
My product group is still addressing the issue, and they found that there is a problem with the Binary router parsing incomplete data .

Still waiting for the fix to be applied. …

If incomplete data is happening on a preview, the file is probably too large. That problem won’t happen if you RUN the mapping though. So if you want to test, keep the files relatively small.