Showing results for 
Search instead for 
Did you mean: 

REST POST a file to

New Contributor

Hi, I’m trying to do a multi-part form REST Post to upload API which requires a file and an attributes part. We’re getting an error indicating that the parent parameter can’t be found. Parent is essentially the folder id in Box. The box API says the call would be sent like so:

-H “Authorization: Bearer ACCESS_TOKEN” -X POST
-F attributes=‘{“name”:“tigers.jpeg”, “parent”:{“id”:“11446498”}}’
-F file=@myfile.jpg

Here’s the sample pipeline Box REST POST_2018_08_29.slp (8.6 KB)

In this iteration I’m creating the attributes as an expression and passing it into the HTTP entity element in the REST POST Snap. I’m not sure how else to pass these attributes data elements to the REST POST call. I feel like I’ve tried everything but doesn’t seem to see the parent attribute which is necessary for the call to succeed. Admittedly, I’m a bit new to using the REST snaps, but hoping someone could throw out some ideas to try. Thank you!



New Contributor II

I’ve been experiencing the same issue as Craig here. I tried replicating the examples from the REST POST documentation on uploading a file, but I don’t seem to be able to pass the ‘parent’ parameter to the API.

Have you tried using the Box snaps instead of the REST snaps?

We did use the snap in a trial and successfully posted a file, however, given a limited budget, was hoping to not have to purchase the box snappack if there wasn’t a need and the REST API could do the trick.

New Contributor II

Same here. Our organization doesn’t have the Box Snap Pack, and I was hoping that I could get generic REST POST functionality out of the REST snap pack.