Showing results for 
Search instead for 
Did you mean: 

Using Azure Storage/Azure Blob Storage

New Contributor II

I am trying to create an Azure Blob Reader but I keep encountering this error:

Error: Directory not found or access denied: wasb:///; Reason: com.snaplogic.snaps.hadoop.BinaryAzureAccount cannot be cast to com.snaplogic.snaps.hadoop.KerberosAccount; Resolution: Please check if the directory exists, you have access right and all Snap properties and credentials are valid.

Failure: Unable to read from wasb:///, Reason: Failed to open input stream for WASB path: wasb:///, detail: The specifed resource name contains invalid characters., Resolution: Please address the reported issue.

I also tried replacing wasb with wasbs but I still get the same error.
Here are some screenshots of my pipeline and I used cyberduck tool to verify I can successfully connect to the Azure storage. I am not sure if using a trial account for Azure is causing this.

30 pm

45 pm

and a cyberduck screenshot
59 pm


Admin Admin

Which version of the Hadoop Snap Pack are you using?
There have been some fixes to the Snap Pack since the 4.10 release:

Diane Miller
Community Manager

New Contributor II

Hi dmiller,

we are using version snapsmrc414 - which i think is version 4.10 release according to this link:


Still trying to figure out as to how it is working in Cyberduck and not in the snaplogic canvas.

I"m talking with Dev about it. I believe there is a known issue.

Diane Miller
Community Manager

There was an update Snap Pack deployed last night, hadoop3887, that should address this issue.

Diane Miller
Community Manager