Forgot password option not work

Hi,

I used to use SSO to do the logins to snaplogic, but now I was added to another org, then I cannot login to any of the org now. I got this error:
image

I want to try to use the username/password to login. But I don’t have a password for my account, so I tried the forgot password option. I’ve tried this option for a couple of times. But I won’t get any email to reset the password. Can anyone help with it? Or tell me what should I do?

Thanks,
Susan

Hi there. You would have to to get taken off one of those orgs. Probably the one where you are manually added.

But I need to work on both of the orgs. I have to keep both. Is there a way to fix this?

Hi Susan - I dont believe you can keep both. It would violate security standards. I would create a ticket with support. They may have a better answer.

Maybe trying creating the manual user with a different email?

Unfortunately, I have to use the company’s email address as the login account

The only way I’ve seen it work is using an alias, like Gmail’s “+” modifier (user@xyz.com and user+nonsso@xyz.com), but then you have to log into each org separately.

See the note at the bottom of SnapLogic SSO. A user can belong to multiple orgs and still use SSO. Enabling this requires that all the orgs the user belongs to be configured to use the same Identity Provider. Without this restriction, there is no way to ensure that the user logging into one org through SSO has been authorized for access to the second org.

In this case, the fix would be to ask the org admin for the second org to configure SSO, with the same details as used for configuring the first org.

1 Like

Right now, I do not have admin access. Why cannot I get the reset password email when I try the forgot password option?

@sdeng You can check in your junk mail box, sometimes it comes there.

If SnapLogic login is disabled for the user account, only SSO login is allowed, then forgot password will not send an email with the reset link. For security reasons, to avoid disclosing whether a user account exists, there is no error message to indicate that the email is not being sent.

If the account is still locked out, do reach out to support@snaplogic.com to help investigate further.