REST GET: Not working for Smartsheet API

Hi,

I’m trying to fetch data from a sheet using Smartsheets sheets API. I’ve generated the access token, and it’s working fine with Postman. Please see below it’s returning the data, but when I do the same using Rest Get, it’s not producing anything.

And also, with Smartsheets API, even if I pass the wrong sheetid its starts validating and does not throw any error. If it’s working in POSTMAN, it should work with REST Get also. Please let me know what I’m missing.

Note: I’ve also tried using the Oauth2 method by creating an account for Smartsheets, and I was able to refresh the token as well, but with that approach, it is also not working.

Hi @mayank.singh ,

Can you please change the Response entity type attribute of the snap to Text and try again?

Regards,
Marjan

Hi @marjan.karafiloski,

Thanks for the reply!
I tried but no luck. The data preview is still empty.
image

Hi,

What is the value for Snap Execution attribute in the snap?

Validate and Execute.

Hi,

Please check Trust all certificates and change the view when error happens to Route error data to error view and try again to see if data or error/s appear after executing.

Thanks. I’ve already tested it for all the snap properties. But still not working. Error view is empty.image

Hi,

By default, the attribute Follow redirects is checked in the REST Get snap. Please check that attribute and also Process array.

If that is not working, please try to get all the data from the API (https://api.smartsheet.com/2.0/sheets).

Try to execute the pipeline by clearing cache (shift + validate).

Regards

I tried but still not working.

Try to remove the authorization header and see if you get an error after executing.

Tried, getting nothing.
If the same thing I do in Postman, I’m getting 1004 error.

Please make print screen of all the attributes of the REST Get snap.

Here:

I’ve tried all the snap properties, still not working.

If I try to validate & execute the snap with same data as you are saying (without authorization), I get the following error:

Please remove the snap and create it from scratch.

And also, can you make print screen of the Views tab, to see how you have set the values when error happens?

Hi @marjan.karafiloski, I created the new snap and didn’t provided the access token; I got the same 403 error. But after I added the access token, again its not returning anything.

I’m using trail account of Smartsheet and created access token for testing purpose.

Let me know if I can share the API key with you. Anyway, it’s for my test account.
Later I’ll delete it.

If you can share it, it would be great. I’ll try to see if I can make it work.
Send it in private message.

I tried with the token that you have sent to me, and it is working perfectly, either for getting all the sheets or getting sheet by ID.


image

4 Likes