Slf4j Conflicts

Hi ,

After developing the custom snap and the deployment.

While running the snap , I am getting the below error.

In the package which I upload , there is third party jar which uses slfj logging.

If I have the slf4j api jar in the package it says the below error

org.slf4j.impl.StaticLoggerBinder.getLoggerFactory()Lorg/slf4j/ILoggerFactory;" the class loader (instance of org/eclipse/jetty/webapp/WebAppClassLoader) of the current class,org/slf4j/LoggerFactory, and the class loader (instance of java/net/FactoryURLClassLoader) for the method's defining class, org/slf4j/impl/StaticLoggerBinder, have different Class objects for the type org/slf4j/ILoggerFactory used in the signature, Reason: Snap failed unexpectedly and did not provide any reason

If I remove it , It says classDefinitionnotfound, Since the class could not be initiated because of missing slf4j jars.

Have you tried including the dependency for slf4j in your pom and setting the scope to provided?

1 Like

Thanks for the response. Yes. In that case I am getting the class could not instantiated. I am verifying it is because of the SLF4j objects or someother static objects causing the ClassDefinitionNotFound for that class .

Hi Harriesh,

I am running into an issue very similar to the one you have raised here, did you ever reach a solution for this?

Many thanks,
Kareem.

Hi Kareem,
No I have not . I have tried all options I get stuck in some place for creating custom snap. But what I know is its environmental issue due to latest upgrades in the snaplogic.

I think they providing a boilerplate for a custom snap will solve this issue. They have not released latest anything like that till now.