Showing results for 
Search instead for 
Did you mean: 

Linking attachments with email body using join snap returns errors

New Contributor III

Hello everyone.

I'm using the Exchange Online Read Email snap to parse the content of the message, and process the attached files according to rules defined in the message.

The Read Email has 2 output views, one for the attachments and the other for the mail itself. The attachment output has a field labelled "email-id" which matches the field labelled "id" from the mail output.

The idea is to use a join to be able to link the attachments with their parent email.


The problem is that my Join snap returns an error that I'm not sure is caused by a misconfiguration from my side, or a real issue with the snap itself. I tried many different configurations for the Join snap, and nothing works.

The error message says:

Failure: Failed to sort input document stream for input view: input1, Reason: java.lang.reflect.InaccessibleObjectException: Unable to make field private final jdk.internal.platform.Metrics accessible: module does not "opens" to unnamed module @3ce6ddc0, Resolution: Please address the reported issue.

Anyone ever experienced such an issue?

Thanks in advance for any help!



Contributor III

Hi @jfpelletier , have you tried setting the sorted streams to "Unsorted" ?


New Contributor III

Hello @alchemiz,

Thanks for your reply! The error message that I reported in the original post is when I do use the "Unsorted" option as you suggest. If I use the default "Ascending" value, the error message is different:

Failure: Failed to perform join operation, Reason: Not ascending order: [null(value: AAMkADIwYmQwMzJhLTQ3YWQtNDY0Ni04YTliLWRlM2JhY2NkMzUwMABGAAAAAACqlsLWwl3zTpiuZt2kjeu4BwCh0wtN9WH0QYJbfsTDukxNAAAAAAEMAACh0wtN9WH0QYJbfsTDukxNAAKH0bTlAAA=, type: String)] and [null(value: AAMkADIwYmQwMzJhLTQ3YWQtNDY0Ni04YTliLWRlM2JhY2NkMzUwMABGAAAAAACqlsLWwl3zTpiuZt2kjeu4BwCh0wtN9WH0QYJbfsTDukxNAAAAAAEMAACh0wtN9WH0QYJbfsTDukxNAAKH0bTjAAA=, type: String)], Resolution: Please address the reported issue.

I also tried to use the "Sort" snap on the outputs just before the "Join", but the "Sort" at the Attachment branch is returning a similar error message.