Showing results for 
Search instead for 
Did you mean: 

NetSuite always trowing an error even if the bill is created successfully

New Contributor

I’m facing an issue with the netsuite create snap. The flow is creating a new bill in netsuite, however the job always returns the below error saying that the reference number is a duplicate even if the bill gets created. I have tried many times adding different references and every time the bill gets created but the response from the netsuite snap is the same:

Have you seen this error?



“An error occurred while executing the SOAP request”


“com.snaplogic.snap.api.SnapDataException: An error occurred while executing the SOAP request\n\tat com.snaplogic.snaps.netsuite.NetSuiteCommon$\n\tat com.snaplogic.snaps.netsuite.NetSuiteCommon$\n\tat com.snaplogic.snaps.netsuite.NetSuiteCommon.doWithRetry(\n\tat com.snaplogic.snaps.netsuite.NetSuiteCommon.postRequest(\n\tat com.snaplogic.snaps.netsuite.NetSuiteCommon.makeRequestWithDocument(\n\tat com.snaplogic.snaps.netsuite.Create.process(\n\tat com.snaplogic.snap.api.ExecutionUtil.process(\n\tat com.snaplogic.snap.api.ExecutionUtil.executeForDocument(\n\tat com.snaplogic.snap.api.ExecutionUtil.execute(\n\tat com.snaplogic.snap.api.SimpleSnap.execute(\n\tat com.snaplogic.snaps.netsuite.NetSuiteCommon.executeForSuggest(\n\tat\n\tat\n\tat\n\tat\n\tat\n\tat java.base/ Source)\n\tat java.base/java.util.concurrent.Executors$ Source)\n\tat java.base/ Source)\n\tat java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)\n\tat java.base/java.util.concurrent.ThreadPoolExecutor$ Source)\n\tat java.base/ Source)\n”


“{soapenv:Body={@xmlns:soapenv=, @xmlns:xsd=XML Schema, @xmlns:xsi=, addResponse={, writeResponse={platformCore:status={, @isSuccess=false, platformCore:statusDetail=[{@type=ERROR, platformCore:code=USER_ERROR, platformCore:message=Duplicate [Reference No. - Vendor] Combination found, saving is not allowed}, {@type=WARN, platformCore:code=WARNING, platformCore:message=Reference No. 123456test6 is a duplicate for this vendor. Click OK to save duplicate or click Cancel and change Reference No.}]}}}}}”


“Please verify that the incoming data is valid and sufficient for the request”





Hi @Alix :

This might require a bit more investigation. The stack trace is helpful, but the error message is from Netsuite. The message indicates a duplicate reference number for the vendor, but you recognize this and it appears you have tried many such numbers.

I’m less familiar with Netsuite setup, so not sure if this can be fixed there.

I would suggest logging a support ticket. We have many folks who are well versed in Netsuite. You can copy and paste this message into the ticket.

New Contributor

Thank you @mbowen , actually it was an error from NetSuite. There is an script within NetSuite causing this behavior. Thanks for your help.