Oracle Bulk Load - SQLLDR Path Issue

Hi,

I am trying to use the Oracle Bulk Load option for inserting the data, currently getting the issue for SQLLDR path. I have provided the path of SQLLDR like this and SQLLDR is available in this path on Oracle Database Server. Tried with both
u01/app/oracle/product/12.1.0/dbhome_1/bin/sqlldr.exe
u01/app/oracle/product/12.1.0/dbhome_1/bin/sqlldr

Error Message
Failure: Specified SQLLDR path is not an executable file, Reason: Snap failed unexpectedly and did not provide any reason

Please could suggest me on the path of SQLLDR.

I believe you need an opening /, as in:
/u01/app/oracle/product/12.1.0/dbhome_1/bin/sqlldr

Tried with opening / as /u01/app/oracle/product/12.1.0/dbhome_1/bin/sqlldr this also did not work.

Have you tried using the suggestions in the snap for this field?
Also make sure the ORACLE_HOME, PATH and ORACLE_SID is set appropriately in the plex for oracle. For example:

export ORACLE_HOME="/u01/app/oracle/product/11.2.0/xe"
export ORACLE_SID=“XE”
export PATH=$ORACLE_HOME/bin:$PATH

Are you running on a Groundplex node that you have access to? (SQLLDR is not available in Cloudplex environments) .

I am executing using Cloud snaplex, Our Oracle DB is also on cloud.

As Oracle bulk load uses the native utility, that is not available in Cloudplex environments. If you want to use endpoints requiring local utilities or libraries then you should use a Groundplex in your own domain, where you can provision those proprietary native resources. Other Snaps which use native libraries include SAP (ECC - BAPI and IDOCS), Tableau TDE formatter and SQL Server Bulk load.

Even I too facing the same issue. unable to access the SQLLDR in Groudplex as well. Kindly suggest me what is the solution for this?

I was using cloudplex, it did not work. Then tried using Groundplex, still did not work.

I tried using the groundplex still the Oracle Bulk load snap is not working. how to configure the SQLLDR ? we are providing the SQLLDR utility path where the DB is located, how the snaplogic can access this SQLLDR? we are providing the DB details not the OS details. Do we need to have the SQLLDR in the snaplogic environment?

Regards,
Hemanth

Yes, the SQLLDR needs to be installed in the Groundplex environment, and configured in the Snap with the path.