Snaplogic API CORS policy (enable try me) disabled still CORS error in api portal

Hi,

I’m trying to acces my data through a get request with an API key as an Authorization. I disabled the checkbox Enable try me button to override the default CORS restriction policy to not use CORS.

In the API manager I have applied two policies:
image
Authorize by Role is mandatory (said in documentation to authenticate the api caller correctly)

But when I do the call in the API portal of Snaplogic (with the API key authorization) I still get the CORS error.


Because I checked the console also and it is a CORS error.

Is there somewhere still CORS enabled in SnapLogic?
When I test it in Postman with the API Key it works correctly

But when I use the policies:

  • Authorize by role
  • anonymous Authenticator
    so you need no Authorization and I can acces the data from the API portal. But then there is no security…

Regards

Jens

Hi,

I finally found the error. So apparantly in the default CORS settings the header ‘authorization’ is not included in the acces control headers request so I needed to override the CORS policy with my own.

I will close this topic in two days

1 Like