Can we hyperlink inside a mapper snap?

Hi Team,

I was tryin to use native JS function link in order to hyperlink inside a mapper. I found that it doesn’t work, does anyone know a similar functionality or a workaround?

Basically, I was trying to hyperlink an existing column “ID” and wanted to output this in an excel file. Snaps below for reference:


Thanking in advance for your help :slight_smile:


If it’s meant to go on Excel you could direcly write down the formula instead ?
“=HYPERLINK(‘’,’”+ $ID +"’)"

1 Like

@Lydia: I’m testing the string you’ve provided and haven’t found any luck yet.
Have you tried the same string on your end?

I also tried to tweak it as I was getting errors but haven’t been able to achieve the results.

Sharing a sample excel data for your convenience (@Lydia)

snapLogic_Excel_HyperLink.xlsx (10.2 KB)

Hum… I’m using a french version of Excel so symbols might be different… But i tried it on my side and it worked

Testing For Excel Link_2022_04_29.slp (6.5 KB)

Maybe try using double quotes
"=HYPERLINK(\"\",\""+ $ID +"\")"

1 Like

You are missing quotes/double quotes around your formula. It’s not a snaplogic formula it’s an excel so you need to treat it as if it was text.
Also i forgot some quotes in my first answer :sweat_smile:

1 Like

@Lydia: The string works now and the mapper doesn’t throw any error however the excel generated keeps it as a string, doesn’t evaluate as a formula, screenshot below:


Any suggestions?

If you clic in the F2 cell and then press enter does the formula gets calculated then ?
I’d think this is because the output printed is “text” so it shows the text until you click it and it understand it’s a formula instead. I’m not sure how you could fix this, this has probably to do with excel settings too…

Yes, clicking enter does the trick in excel and I tried to put an excel parser in the pipeline too (as it has the option of calculating the formulas) but the pipeline gets complicated as at the end as we would need to use a combination of mapper, document to binary, parser, etc.

I tried using the below pipeline so that formulas get calculated but didn’t find any luck:

The final output in the excel file remains as is:

Similar discussion is being carried forward on a different thread:

Reading files from SL manager?

Looping in the SMEs for their suggestions on this one…

CC: @robin @dmiller @Spiro_Taleski @bojanvelevski @siwadon @Supratim @alchemiz

Any chance you have auto-hyperlink disabled?
In Excel, under Tool > Autocorrect options, is Replace internet and network paths with hyperlinks selected?

Thank you @dmiller for your quick response. I do have it selected as default. Screenshot below for your reference:

For my version of excel, it was under

Excel > File > Options > Proofing > AutoCorrect options > AutoFormat As You Type > Replace as you type: Internet and network paths with hyperlinks

@darshthakkar , do you have RPE - Remote Python Executor enabled on your snaplex?


I also found a “workaround” but I’m not sure if that will work for you because minimal manual action is required.

If you use CSV Formatter, instead of Excel, but still use Microsoft Excel to open the file, the hyperlink formula will be evaluated and you can save the file as .xlsx document.

1 Like

Not sure of this @bojanvelevski, how do we check it?

Thanks @bojanvelevski, I will try this…

@bojanvelevski: This is amazing, it works!

I tried reading the same CSV file (shown in the snap above) and convert it in snapLogic but the hyperlink doesn’t work there, I believe the workaround should do for now, thanks for testing this @bojanvelevski

1 Like

Thank you @Lydia and @bojanvelevski for your help on this one. As I can only mark a single comment as a solution, I wouldn’t do justice to one of you but without both of you, this thread wouldn’t have been concluded.

Thank you @Lydia for providing the formula for hyperlink "=HYPERLINK(\"\",\""+$ID+"\")" and letting me know that a manual intervention in excel would be needed to just go over that cell and click “Enter” for the formula to work.

Thank you @bojanvelevski for sharing the workaround of using a CSV Formatter instead of an Excel Formatter, that solution really helped although it does have a manual intervention but lesser than the one stated above (by going into each cells and activating the formulas)

I’m marking this as a solution intentionally so that I can give credits to both of you and anyone referring to this thread can get best of both the worlds in a single comment.

Thank you!

Signing off from this thread as workaround will do the trick for now.

Best Regards,

P.S. Doesn’t mean that I don’t appreciate your efforts and wanted to offend either of you.

CC: @dmiller @robin
#multiplesolutions #creditsharing