Does anyone have experience of accessing files on a windows network file share?

The file writer snap is not cooperating, it’s says it’s succeeding but doesn’t appear to do anything.

Currently have an account mapped with read/write permissions, using fille:/// anything else generates an error or creates a file with a weird name on the plex.

any help much appreciated.

Yours,

Adrian

Hi Adrian,

Are you using file:/// to access the share, or smb:///?

Cheers
Nic

Nearly….

Trying for some reason to use file:///<file:///\> to access the network share z://, converting to SMB now.

Yours,

Adrian

@AdrianH, We interface with a file share on many of our pipelines using thing following environment and parameters:

  • Groundplex Nodes running on Windows Server on AD Network
  • Groundplex Nodes running as a Windows Service with specified logon credentials (not as System or Local Network)
  • Above mentioned logon credentials have R/W access to both the network share and target file path
  • The Snap’s file name value requires four "/"s in the protocol spec: “file:////{server}/{share}/{path}/{path}/{filename}”

The above works for us, so we have not tried actually mapping the file share to a drive letter.

1 Like

We are facing a similar issue where a network drive is not accessible on windows machine. Tried with above given suggestions but it doesn’t seem to work for us
"file:////{server}/{share}/{path}/{path}/{filename}"

Anybody else facing the issue or have resolved it recently?

what @del mentioned is a straightforward configuration. Please work with the support to get it resolved.

@nganapathiraju I have contacted Support and waiting for their help.
We are using Basic Auth as account type, if it has any correlation with the issue we are facing for network drive access on windows machine.

You’re going to need to run your snaplex node(s) as an Active Directory account that has been granted permissions to the share (or the machine granted permissions). The account type of Basic Auth is not necessary.

In other words… If you’re running the node as a Windows Service, you need to click the Log On tab of the service configuration and assign an account that has been granted permissions to the share ACL. Example: image

Thanks a lot Del, it worked with your help.