Error while trying to Upgrade Java 8 to Java 11

Hi,
We are working on Upgrading the Groundplex nodes from Java 8 to Java 11, I am following the steps mentioned in the below link

https://docs-snaplogic.atlassian.net/wiki/spaces/SD/pages/850067457/Configuring+the+Java+Version+on+your+Groundplex#ConfiguringtheJavaVersiononyourGroundplex-UpgradeProcess

But when I run the following command the I am getting this error
sudo dpkg -i snaplogic-snaplex.deb
dpkg: error processing archive snaplogic-snaplex.deb (–install):
** cannot access archive: No such file or directory**
Errors were encountered while processing:
** snaplogic-snaplex.deb**

Can someone please help me out with this.

Thanks,
Sandeep.

@sandeep_manda, you should give the name of the downloaded file.
Ex: sudo dpkg -i snaplogic-sidekick-4.main-8600-x86_64.deb

Hi @SatyaK, I have downloaded the deb file from the Shared/Snaplexes/Downloads onto my linux server and then ran the command
sudo dpkg -i snaplogic-sidekick-4.main-8600-x86_64.deb

and got the below error:
(Reading database … 831619 files and directories currently installed.)
Preparing to unpack snaplogic-sidekick-4.main-8600-x86_64.deb …
Unpacking snaplogic-sidekick (4.main-8600) over (4.master-4403) …
dpkg: dependency problems prevent configuration of snaplogic-sidekick:
snaplogic-sidekick depends on fontconfig; however:
Package fontconfig is not installed.

dpkg: error processing package snaplogic-sidekick (–install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
snaplogic-sidekick

I also ran the below command using the deb file which was already on my Linux server (which was copied there back in 2018)
sudo dpkg -i ./snaplogic-sidekick-4.master-4403-x86_64_v4.deb

Then I got a message saying ‘Sidekick successfully installed’
(Reading database … 831978 files and directories currently installed.)
Preparing to unpack …/snaplogic-sidekick-4.master-4403-x86_64_v4.deb …
Unpacking snaplogic-sidekick (4.master-4403) over (4.main-8600) …
dpkg: warning: unable to delete old directory ‘/opt/snaplogic/etc’: Directory not empty
Setting up snaplogic-sidekick (4.master-4403) …

SnapLogic Sidekick successfully installed.

But when I look inside the /opt/snaplogic/pkgs/ folder I only see jre1.8.0_162 . I was hoping to see Java 11 in there too

Can we please get on a call if its easier to debug this issue?

The latest package is looking for fontconfig dependency. If you are using OpenJDK 11 in the Snaplex on which you want to execute Excel Formatter Snaps, you must install Fontconfig on the Snaplex. Otherwise, the Snap displays an error. Please install fontconfig and then proceed to install new deb file.

To install Fontconfig, run the following command:

  • On Ubuntu/Debian deb based systems:
    apt install fontconfig
  • On Fedora/CentOS rpm based systems:
    yum install fontconfig

Hi @SatyaK, Thanks a lot for the prompt response.

Hi @SatyaK, after installing fontconfig I was successfully able to install snaplogic-sidekick-4.main-8600-x86_64.deb
After the installation when I look in /opt/snaplogic/pkgs/ folder I now see both jdk-11.0.8+10-jre & jre1.8.0_202
But when I run the command java -version , I do not see jdk 11 in the list.
image

So, I am not totally sure if my upgrade to Java 11 was successful or not. Can you please let me know if I missed any steps?