How to pass mapper column in Rest API filter condition

Hi,

I have a requiremnet, where i need to pass the mapper Date column (which i read from oracle table) in REST API filter condition. i tried with below syntax, but it is giving error. please someone can advice here.

Created gt datetime’" + $CREATED + "’

if i hardoce the date value it is working — Created gt datetime’2020-04-02T11:00:00’

since you are using an expression, try enabling the = button for that field and quoting the strings.

Hi Miller,

I enabled ‘=’ button and used below expression, but it is throwing error.

Created gt datetime’" + $CREATED + "’

I tried with below syntax, still it is giving same error

It looks like your quotations are off. Are you trying to concatenate the string “created gt datetime” and the date stored in $CREATED ?

If so try this: “created gt datetme” + $CREATED

Notice the variable $CREATED is not in quotes and the static string portion is.

Hi ,

I tried as you said, but it is giving same error as bad request.

My Pipeline is very simple. i am trying to read date column from Oracle table, passing it through mapper, and then using it in Rest Get filter.



Not sure what your rest endpoint is expecting, but to mimic the same value when hard coding the date you may need the single quotes like this:

“Created gt datetime ‘“ + $CREATED + “‘“

Where you are surrounding the value in $CREATED with single quotes similar to your hard coded string/date example

Hi Howard,

Thanks for the help and input.
It worked when I use the Oracle Select Snap, instead of Oracle Execute.

I am very great ful for your help.

1 Like

No problem. Glad it is working.

Just an FYI, disabling the first snap In a branch of snaps will disable all downstream snaps as well. So, for that branch in your screenshot of all disabled snaps, you can just disable the first one and have the same effect. Just to save you time from disabling and enabling all of them.