File references in SnapLogic

Hello All,

We have a pipeline where we are referring to an external expression lib for some transformation.

I am getting the “file not found” when the same pipeline is being invoked from some other project’s pipeline.

Wanted to understand how the references are made for files in snaplogic.

/KS

In "edit pipeline, it is the very last option:

Of course, you have to upload it in the same directory as the pipeline, (often …/shared/), and that is equivalent to just uploading the file through the manager. I don’t BELIEVE the name makes a difference, but making that, the filename, and the library name itself the same name is generally good practice.

Yeah, i placed the file under the directory where my pipeline resides which is mainly being called from another parent pipeline from the same directory.

However we have designed a reprocess pipeline, which will invoke all the failed pipelines and in thins case the reference is breaking. I am not sure how can that be fixed.

Also would like to know if there is any restriction on the size of the ‘.expr’ file.
I am trying to import a 3 MB file which has typemap for a specific key/value mapping.

When the whole file is referred the gives error “can not parse the file” when the same file is given with small amount of data it gets imported without any issue.

In any pipeline that directly uses an expr file, you should have the pipeline refer to the expr file, as I indicated above.

I can’t imagine that 3MB is too big for the expr file. Have you tried actually running it, as opposed to preview? The preview has a limit, and it can cause the error you are talking about, though it is hard to believe it would affect expr files. The ones I am using are TINY.

Yeah the same error persist even while running.

Given what I know now, I guess I am not sure what is going on. Is it possible that you are using different snaplexes, or orgs? Either one could cause a problem here. I am even doing three levels myself, and all seem to work. I have the first that loads the parameters. the sedcond that starts and monitors the tasks, and the third that actually does the tasks.

not sure if my question is clear enough, let me restate the problem

  1. Having issue in loading 3 MB expression library
  2. Exp lib place in child directory not accessible by pipeline placed in root shared folder.

You may need to contact SnapLogic Support.
Email support@snaplogic.com with your findings.