Set up error pipeline

I have configured error pipeline but the error is not passing into input view. Need help to configure this. Thanks
error pipe_2020_08_27.slp (2.2 KB) rest api_2020_08_27.slp (2.7 KB)

I imported your pipelines. They work as expected. The error is being transformed by the Mapper in the error pipeline: the entire response is under “path”.

thanks @ptaylor.
below error when validating parent pipeline

mapper config

There is no Mapper in the main pipeline you attached to your first post. Did you add one? You can’t process errors that were sent to the error pipeline in the main pipeline. That’s what the error pipeline is for. Try doing all the error processing there.

For pipelines which use an error pipeline, it is possible to do custom error handling for some snaps before passing the error document to the error pipeline. For example,


the Postgres Insert here does not directly send its error to the error pipeline, it is configured to “Route Error Data to Error View”. The error goes to a mapper which adds some additional metadata to the error document. Right-clicking on the mapper gives an option to “Link Output to Error Pipeline” which makes the mapper’s output go to the error pipeline. This allows for custom error handling while using an error pipeline.

the below error output from main pipeline(REST API snap) is as expected.

below is the configuration in the mapper snap from error pipeline

output of mapper snap. I am trying to process the output of mapper snap

@akidave I tried your suggestion

in the error pipeline the mapper snap is configured as

rest api_2020_08_27_.slp (4.5 KB) error pipe_2020_08_27_.slp (2.3 KB)

Both of the screen captures in your last reply to me are corrupted and I can’t see them.

From your most recent reply to akidave, it looks like you’re trying to validate the error pipeline by itself. That won’t work, since it has no input. The way I’ve dealt with this to develop the error pipeline is to add a JSON Generator add the beginning containing sample error document(s) I want it to process. When it’s working, detach and disable that snap.